aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-04 16:45:32 -0800
committerTed Gould <ted@gould.cx>2010-02-04 16:45:32 -0800
commit33edaca78f98d3a4b0f1eccf7076b3c659ec90e4 (patch)
tree56db9b794df727e4f7a717e85b9ec49600c69a66 /tests/Makefile.am
parentf25e2f07b3afbdfbe6088bb913cf091620a4ad16 (diff)
parentf8ab455538c130ce03132e2557c9363e9a808156 (diff)
downloadayatana-indicator-application-33edaca78f98d3a4b0f1eccf7076b3c659ec90e4.tar.gz
ayatana-indicator-application-33edaca78f98d3a4b0f1eccf7076b3c659ec90e4.tar.bz2
ayatana-indicator-application-33edaca78f98d3a4b0f1eccf7076b3c659ec90e4.zip
* Upstream release 0.0.11
* Interoperability Fixes * Adding in XVFB support for tests * Adding support for icons with the '-panel' suffix
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c94ebdd..327c8cc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,8 @@ check_PROGRAMS = \
TESTS =
DISTCLEANFILES = $(TESTS)
+EXTRA_DIST = run-xvfb.sh
+
#########################################
## test-libappindicator
#########################################
@@ -89,7 +91,8 @@ test_libappindicator_fallback_item_LDADD = \
$(top_builddir)/src/libappindicator.la
test-libappindicator-fallback: test-libappindicator-fallback-watcher test-libappindicator-fallback-item Makefile.am
- @echo "#!/bin/sh" > $@
+ @echo "#!/bin/bash" > $@
+ @echo . $(srcdir)/run-xvfb.sh >> $@
@echo $(DBUS_RUNNER) --task ./test-libappindicator-fallback-watcher --task-name Watcher --ignore-return --task ./test-libappindicator-fallback-item --task-name Item >> $@
@chmod +x $@