aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-01 09:19:33 -0600
committerTed Gould <ted@gould.cx>2009-12-01 09:19:33 -0600
commit113fc34a5865253cd1508cce2973eb7aefddc2ab (patch)
tree5617ea7082f91be64719002a5cb2aa5b8e76a3ca /tests/Makefile.am
parent71797b37811381cfb48e711348a1259f02bdd125 (diff)
parent1933cc6afeee8293363b5204f0bc9b94643f22dd (diff)
downloadayatana-indicator-application-113fc34a5865253cd1508cce2973eb7aefddc2ab.tar.gz
ayatana-indicator-application-113fc34a5865253cd1508cce2973eb7aefddc2ab.tar.bz2
ayatana-indicator-application-113fc34a5865253cd1508cce2973eb7aefddc2ab.zip
Updating to service-me-please branch.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dfdb397..0b771db 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
check_PROGRAMS = \
test-libcustomindicator \
test-libcustomindicator-dbus-client \
- test-libcustomindicator-dbus-server
+ test-libcustomindicator-dbus-server \
+ test-simple-app
TESTS =
DISTCLEANFILES = $(TESTS)
@@ -87,3 +88,19 @@ test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustom
TESTS += test-libcustomindicator-dbus
+#########################################
+## test-simple-app
+#########################################
+
+test_simple_app_SOURCES = \
+ test-simple-app.c
+
+test_simple_app_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_simple_app_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+