aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-01 09:15:05 -0600
committerTed Gould <ted@gould.cx>2009-12-01 09:15:05 -0600
commitc860f693411ceb717267f8b1873dd91613723f3b (patch)
tree5e08982df3244b08e76b64c827b98641b7bb4950 /tests/Makefile.am
parent88be27c0e1f3a54658d4e3740ef9ae4632e30b8b (diff)
parentf23c54ff5fee5587c31ecb8bf176b58fa3d4be1d (diff)
downloadayatana-indicator-application-c860f693411ceb717267f8b1873dd91613723f3b.tar.gz
ayatana-indicator-application-c860f693411ceb717267f8b1873dd91613723f3b.tar.bz2
ayatana-indicator-application-c860f693411ceb717267f8b1873dd91613723f3b.zip
* Flesh out the library to have stuff working.
* Updating test suite to run under dbus-test-runner.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am89
1 files changed, 89 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..dfdb397
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,89 @@
+
+check_PROGRAMS = \
+ test-libcustomindicator \
+ test-libcustomindicator-dbus-client \
+ test-libcustomindicator-dbus-server
+
+TESTS =
+DISTCLEANFILES = $(TESTS)
+
+#########################################
+## test-libcustomindicator
+#########################################
+
+test_libcustomindicator_SOURCES = \
+ test-libcustomindicator.c
+
+test_libcustomindicator_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libcustomindicator_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+
+#########################################
+## test-libcustomindicator-dbus-client
+#########################################
+
+test_libcustomindicator_dbus_client_SOURCES = \
+ test-defines.h \
+ test-libcustomindicator-dbus-client.c
+
+test_libcustomindicator_dbus_client_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libcustomindicator_dbus_client_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+
+#########################################
+## test-libcustomindicator-dbus-server
+#########################################
+
+test_libcustomindicator_dbus_server_SOURCES = \
+ test-defines.h \
+ test-libcustomindicator-dbus-server.c
+
+test_libcustomindicator_dbus_server_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libcustomindicator_dbus_server_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+
+#########################################
+## Actual tests
+#########################################
+
+XML_REPORT = libcustomindicator-check-results.xml
+HTML_REPORT = libcustomindicator-check-results.html
+
+libcustomindicator-tests: libcustomindicator-tests-gtester Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo $(DBUS_RUNNER) --task ./libcustomindicator-tests-gtester >> $@
+ @chmod +x $@
+
+libcustomindicator-tests-gtester: test-libcustomindicator Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-libcustomindicator >> $@
+ @chmod +x $@
+
+TESTS += libcustomindicator-tests
+DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT) libcustomindicator-tests-gtester
+
+
+DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+
+test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustomindicator-dbus-server Makefile.am
+ @echo "#!/bin/sh" > test-libcustomindicator-dbus
+ @echo $(DBUS_RUNNER) --task ./test-libcustomindicator-dbus-client --task-name Client --task ./test-libcustomindicator-dbus-server --task-name Server --ignore-return >> test-libcustomindicator-dbus
+ @chmod +x test-libcustomindicator-dbus
+
+TESTS += test-libcustomindicator-dbus
+