aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-11-24 21:50:50 -0600
committerTed Gould <ted@gould.cx>2009-11-24 21:50:50 -0600
commitf0fcaa6a2ae71510adc036335c4f84ae6bf33f4c (patch)
treedc31888f2106019130da16fb1af5e1bba63bb46b /tests/Makefile.am
parentf23c54ff5fee5587c31ecb8bf176b58fa3d4be1d (diff)
parent8c7ce8faffe025e5c5cf8f4f23d9cf97cf719533 (diff)
downloadayatana-indicator-application-f0fcaa6a2ae71510adc036335c4f84ae6bf33f4c.tar.gz
ayatana-indicator-application-f0fcaa6a2ae71510adc036335c4f84ae6bf33f4c.tar.bz2
ayatana-indicator-application-f0fcaa6a2ae71510adc036335c4f84ae6bf33f4c.zip
A bunch of code.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dfdb397..0b771db 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
check_PROGRAMS = \
test-libcustomindicator \
test-libcustomindicator-dbus-client \
- test-libcustomindicator-dbus-server
+ test-libcustomindicator-dbus-server \
+ test-simple-app
TESTS =
DISTCLEANFILES = $(TESTS)
@@ -87,3 +88,19 @@ test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustom
TESTS += test-libcustomindicator-dbus
+#########################################
+## test-simple-app
+#########################################
+
+test_simple_app_SOURCES = \
+ test-simple-app.c
+
+test_simple_app_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_simple_app_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+