aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-01-13 12:30:30 -0600
committerTed Gould <ted@gould.cx>2010-01-13 12:30:30 -0600
commit21c5cc4a70c060c12c3fa7082874724c6ac96706 (patch)
tree8eb50c8cc6f2ca9f3c2bdd8b75c6961b3b5e8858 /tests/Makefile.am
parent5ca2ed3d2bb3672888620f17d91f215797d47dd8 (diff)
parentb1b9134542bd3bcfa6b5492f0a7f1b83cf0ec32f (diff)
downloadayatana-indicator-application-21c5cc4a70c060c12c3fa7082874724c6ac96706.tar.gz
ayatana-indicator-application-21c5cc4a70c060c12c3fa7082874724c6ac96706.tar.bz2
ayatana-indicator-application-21c5cc4a70c060c12c3fa7082874724c6ac96706.zip
* Upstream update
* Fallback support
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 845b41c..c94ebdd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,6 +3,8 @@ check_PROGRAMS = \
test-libappindicator \
test-libappindicator-dbus-client \
test-libappindicator-dbus-server \
+ test-libappindicator-fallback-watcher \
+ test-libappindicator-fallback-item \
test-simple-app
TESTS =
@@ -59,6 +61,41 @@ test_libappindicator_dbus_server_LDADD = \
$(top_builddir)/src/libappindicator.la
#########################################
+## test-libappindicator-fallback
+#########################################
+
+test_libappindicator_fallback_watcher_SOURCES = \
+ test-libappindicator-fallback-watcher.c
+
+test_libappindicator_fallback_watcher_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libappindicator_fallback_watcher_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libappindicator.la
+
+test_libappindicator_fallback_item_SOURCES = \
+ test-libappindicator-fallback-item.c
+
+test_libappindicator_fallback_item_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libappindicator_fallback_item_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libappindicator.la
+
+test-libappindicator-fallback: test-libappindicator-fallback-watcher test-libappindicator-fallback-item Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo $(DBUS_RUNNER) --task ./test-libappindicator-fallback-watcher --task-name Watcher --ignore-return --task ./test-libappindicator-fallback-item --task-name Item >> $@
+ @chmod +x $@
+
+TESTS += test-libappindicator-fallback
+
+#########################################
## Actual tests
#########################################