aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-22 09:30:59 -0500
committerTed Gould <ted@canonical.com>2009-10-22 09:30:59 -0500
commit23b72422d828dd77909f6cc11947f9fb5e8cee2c (patch)
tree803d878e48d304cefdf5f434af70b3fab3adb726 /tests/Makefile.am
parentbca9b7ee96632e7c89092184c174b45722e0511c (diff)
downloadayatana-indicator-application-23b72422d828dd77909f6cc11947f9fb5e8cee2c.tar.gz
ayatana-indicator-application-23b72422d828dd77909f6cc11947f9fb5e8cee2c.tar.bz2
ayatana-indicator-application-23b72422d828dd77909f6cc11947f9fb5e8cee2c.zip
Switching to using a little autotest as well.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 18 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8327a79..f6a0525 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,6 +4,9 @@ check_PROGRAMS = \
test-libcustomindicator-dbus-client \
test-libcustomindicator-dbus-server
+TESTS =
+DISTCLEANFILES = $(TESTS)
+
#########################################
## test-libcustomindicator
#########################################
@@ -61,10 +64,21 @@ test_libcustomindicator_dbus_server_LDADD = \
XML_REPORT = libcustomindicator-check-results.xml
HTML_REPORT = libcustomindicator-check-results.html
-libcustomindicator-tester: test-libcustomindicator
- gtester -k --verbose -o=$(XML_REPORT) ./test-libcustomindicator
+libcustomindicator-tests: test-libcustomindicator
+ @echo "#!/bin/sh" > libcustomindicator-tests
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-libcustomindicator >> libcustomindicator-tests
+ @chmod +x libcustomindicator-tests
+
+TESTS += libcustomindicator-tests
+DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT)
+
+
+DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
-check-local: libcustomindicator-tester
+test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustomindicator-dbus-server Makefile.am
+ @echo "#!/bin/sh" > test-libcustomindicator-dbus
+ @echo $(DBUS_RUNNER) --task ./test-libcustomindicator-dbus-client --task-name Client --task ./test-libcustomindicator-dbus-server --task-name Server --ignore-return >> test-libcustomindicator-dbus
+ @chmod +x test-libcustomindicator-dbus
-DISTCLEANFILES = $(XML_REPORT) $(HTML_REPORT)
+TESTS += test-libcustomindicator-dbus