aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-09 00:14:54 -0600
committerTed Gould <ted@canonical.com>2009-11-09 00:14:54 -0600
commit23d6b5d0da79ac8afaff855f0eed4811615999f3 (patch)
tree574c2ff76a61f493481eb46e348c57668d76679d /tests/Makefile.am
parentd0abddaaf72e621a495871e5805cd39a51891b2b (diff)
downloadayatana-indicator-application-23d6b5d0da79ac8afaff855f0eed4811615999f3.tar.gz
ayatana-indicator-application-23d6b5d0da79ac8afaff855f0eed4811615999f3.tar.bz2
ayatana-indicator-application-23d6b5d0da79ac8afaff855f0eed4811615999f3.zip
Adding a defualt file for a little appliction that'll grow into a full app.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f6a0525..39cd3a6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
check_PROGRAMS = \
test-libcustomindicator \
test-libcustomindicator-dbus-client \
- test-libcustomindicator-dbus-server
+ test-libcustomindicator-dbus-server \
+ test-simple-app
TESTS =
DISTCLEANFILES = $(TESTS)
@@ -82,3 +83,19 @@ test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustom
TESTS += test-libcustomindicator-dbus
+#########################################
+## test-simple-app
+#########################################
+
+test_simple_app_SOURCES = \
+ test-simple-app.c
+
+test_simple_app_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_simple_app_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+