aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-20 23:47:20 -0500
committerTed Gould <ted@canonical.com>2009-10-20 23:47:20 -0500
commit5e928c9ce0cbeaa1a1050a7c0e8f10fb7027514c (patch)
treec74383c80b2bf4494e94d631773ed52cf5b4a8ea /tests/Makefile.am
parentd28010e3f12c8d7e03fa6ef9233b3f1d3ebfaac2 (diff)
downloadayatana-indicator-application-5e928c9ce0cbeaa1a1050a7c0e8f10fb7027514c.tar.gz
ayatana-indicator-application-5e928c9ce0cbeaa1a1050a7c0e8f10fb7027514c.tar.bz2
ayatana-indicator-application-5e928c9ce0cbeaa1a1050a7c0e8f10fb7027514c.zip
Now we're building a test, woot!
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 82ec364..4044617 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,26 @@
-# Something here
+check_PROGRAMS = \
+ test-libcustomindicator
+
+test_libcustomindicator_SOURCES = \
+ test-libcustomindicator.c
+
+test_libcustomindicator_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libcustomindicator_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+
+XML_REPORT = libcustomindicator-check-results.xml
+HTML_REPORT = libcustomindicator-check-results.html
+
+libcustomindicator-tester: test-libcustomindicator
+ gtester -o=$(XML_REPORT) ./test-libcustomindicator
+
+check-local: libcustomindicator-tester
+
+DISTCLEANFILES = $(XML_REPORT) $(HTML_REPORT)