aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-12 09:26:50 -0500
committerTed Gould <ted@gould.cx>2010-07-12 09:26:50 -0500
commit7ef183418aaee73864e44d93b32e80962fdea07a (patch)
tree4bf494ab0e9a5605e97f4066bb4ac9d5fb851462 /tests/Makefile.am
parent1ddd622e7f2ab0142c826459e1a38fec926c4dc6 (diff)
parent25b69bb08e3e5a3df7037f8ac786422ff53f6425 (diff)
downloadayatana-indicator-application-7ef183418aaee73864e44d93b32e80962fdea07a.tar.gz
ayatana-indicator-application-7ef183418aaee73864e44d93b32e80962fdea07a.tar.bz2
ayatana-indicator-application-7ef183418aaee73864e44d93b32e80962fdea07a.zip
Putting in a basic approver API.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8d356bc..867d4de 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,6 @@
check_PROGRAMS = \
+ test-approver \
test-libappindicator \
test-libappindicator-dbus-client \
test-libappindicator-dbus-server \
@@ -99,6 +100,32 @@ test_libappindicator_status_server_LDADD = \
$(top_builddir)/src/libappindicator.la
#########################################
+## test-approver
+#########################################
+
+test_approver_SOURCES = \
+ test-approver.c
+
+test_approver_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src \
+ -I$(top_builddir)/src
+
+test_approver_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libappindicator.la
+
+test-approver-tester: test-approver Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo . $(srcdir)/run-xvfb.sh >> $@
+ @echo $(DBUS_RUNNER) --task $(builddir)/test-approver --task-name Approver --task $(top_builddir)/src/indicator-application-service --task-name Service --ignore-return >> $@
+ @chmod +x $@
+
+TESTS += test-approver-tester
+
+
+#########################################
## test-libappindicator-fallback
#########################################