aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-09 16:47:45 -0500
committerTed Gould <ted@gould.cx>2010-07-09 16:47:45 -0500
commit8072a97d30c0e3aaa9f02b89f53ae9af247e473b (patch)
treedebb9a1b27c278b23240695722a159f507e55c1f /tests/Makefile.am
parent306a78b6a438f0702d7f8475e726de53a7a7b66c (diff)
downloadayatana-indicator-application-8072a97d30c0e3aaa9f02b89f53ae9af247e473b.tar.gz
ayatana-indicator-application-8072a97d30c0e3aaa9f02b89f53ae9af247e473b.tar.bz2
ayatana-indicator-application-8072a97d30c0e3aaa9f02b89f53ae9af247e473b.zip
Adding a new sample approver
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8d356bc..a920a20 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,6 @@
check_PROGRAMS = \
+ test-approver \
test-libappindicator \
test-libappindicator-dbus-client \
test-libappindicator-dbus-server \
@@ -99,6 +100,21 @@ test_libappindicator_status_server_LDADD = \
$(top_builddir)/src/libappindicator.la
#########################################
+## test-approver
+#########################################
+
+test_approver_SOURCES = \
+ test-approver.c
+
+test_approver_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_approver_LDADD = \
+ $(INDICATOR_LIBS)
+
+#########################################
## test-libappindicator-fallback
#########################################