aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-02 11:57:06 -0600
committerTed Gould <ted@gould.cx>2009-12-02 11:57:06 -0600
commit29ef598378429811715f727295f40bbcdb3fa092 (patch)
tree6b40b05a5679d50b2128d80bea770cd8f91fa3a5 /tests/Makefile.am
parent71797b37811381cfb48e711348a1259f02bdd125 (diff)
parent69448c00ed4dec738e32cc78f916a110fcd6d3a7 (diff)
downloadayatana-indicator-application-29ef598378429811715f727295f40bbcdb3fa092.tar.gz
ayatana-indicator-application-29ef598378429811715f727295f40bbcdb3fa092.tar.bz2
ayatana-indicator-application-29ef598378429811715f727295f40bbcdb3fa092.zip
Implementing the service and having the indicator and app
library start using it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dfdb397..0b771db 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
check_PROGRAMS = \
test-libcustomindicator \
test-libcustomindicator-dbus-client \
- test-libcustomindicator-dbus-server
+ test-libcustomindicator-dbus-server \
+ test-simple-app
TESTS =
DISTCLEANFILES = $(TESTS)
@@ -87,3 +88,19 @@ test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustom
TESTS += test-libcustomindicator-dbus
+#########################################
+## test-simple-app
+#########################################
+
+test_simple_app_SOURCES = \
+ test-simple-app.c
+
+test_simple_app_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_simple_app_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+