aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-23 14:55:06 -0600
committerTed Gould <ted@canonical.com>2009-11-23 14:55:06 -0600
commit59b0398609ef5ce6ee991c633eb84c3b55a42ac3 (patch)
treeb81beec36b41653eb49717110b3655515a5637c3 /tests/Makefile.am
parent97388871ba0a4669792bead5878ec1eec24a2118 (diff)
parent2c04418795e644efafc0204656dd575844ba0976 (diff)
downloadayatana-indicator-application-59b0398609ef5ce6ee991c633eb84c3b55a42ac3.tar.gz
ayatana-indicator-application-59b0398609ef5ce6ee991c633eb84c3b55a42ac3.tar.bz2
ayatana-indicator-application-59b0398609ef5ce6ee991c633eb84c3b55a42ac3.zip
Adding more fun. Now we're cookin'!
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f6a0525..39cd3a6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
check_PROGRAMS = \
test-libcustomindicator \
test-libcustomindicator-dbus-client \
- test-libcustomindicator-dbus-server
+ test-libcustomindicator-dbus-server \
+ test-simple-app
TESTS =
DISTCLEANFILES = $(TESTS)
@@ -82,3 +83,19 @@ test-libcustomindicator-dbus: test-libcustomindicator-dbus-client test-libcustom
TESTS += test-libcustomindicator-dbus
+#########################################
+## test-simple-app
+#########################################
+
+test_simple_app_SOURCES = \
+ test-simple-app.c
+
+test_simple_app_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_simple_app_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+