aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/mono/examples/Makefile.am')
-rw-r--r--bindings/mono/examples/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/bindings/mono/examples/Makefile.am b/bindings/mono/examples/Makefile.am
new file mode 100644
index 0000000..b929492
--- /dev/null
+++ b/bindings/mono/examples/Makefile.am
@@ -0,0 +1,12 @@
+ASSEMBLY = IndicatorExample.exe
+CSFILES = IndicatorExample.cs
+CLEANFILES = $(ASSEMBLY)
+
+EXTRA_DIST = $(CSFILES)
+
+references = $(GTK_SHARP_LIBS) -r:$(top_builddir)/bindings/mono/appindicator-sharp.dll
+
+$(ASSEMBLY): $(CSFILES) Makefile.am
+ $(CSC) $(CSFLAGS) -out:$(ASSEMBLY) -target:exe $(references) $(srcdir)/$(CSFILES)
+
+all: $(ASSEMBLY)