aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9d5b26d..bd3c6a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-AC_INIT(indicator-application, 0.0.21, ted@canonical.com)
+AC_INIT(indicator-application, 0.2.1, ted@canonical.com)
AC_COPYRIGHT([Copyright 2009, 2010 Canonical])
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-application, 0.0.21)
+AM_INIT_AUTOMAKE(indicator-application, 0.2.1)
AM_MAINTAINER_MODE
@@ -53,6 +53,18 @@ AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
###########################
+# GObject Introspection
+###########################
+
+GOBJECT_INTROSPECTION_CHECK([0.6.7])
+
+###########################
+# Vala API Generation
+###########################
+
+AC_PATH_PROG([VALA_API_GEN], [vapigen])
+
+###########################
# Check for Mono support
###########################
@@ -178,7 +190,7 @@ AC_MSG_RESULT($PYGTK_CODEGEN)
AC_OUTPUT([
Makefile
src/Makefile
-src/libappindicator/appindicator-0.1.pc
+src/appindicator-0.1.pc
bindings/Makefile
bindings/mono/Makefile
bindings/mono/appindicator-sharp.dll.config