aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d97cbeb..8613550 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,15 @@ AS_IF([test "x$with_gtk" = x3],
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
+###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
@@ -134,4 +143,5 @@ Application Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
GTK+ Version: $with_gtk
+ gcov: $use_gcov
])