aboutsummaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 3aedd60..10d8b2a 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -50,12 +50,26 @@ FIXXREF_OPTIONS=
# Used for dependencies. The docs will be rebuilt if any of these change.
# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
-HFILE_GLOB=$(top_srcdir)/src/*.h
-CFILE_GLOB=$(top_srcdir)/src/*.c
+HFILE_GLOB=$(top_srcdir)/src/app-indicator*.h
+CFILE_GLOB=$(top_srcdir)/src/app-indicator*.c
# Header files to ignore when scanning.
# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
-IGNORE_HFILES=app-indicator-enum-types.h application-service-appstore.h application-service-client.h application-service-marshal.h application-service-server.h application-service-watcher.h dbus-properties-client.h dbus-properties-server.h dbus-shared.h notification-item-client.h notification-item-server.h notification-watcher-client.h notification-watcher-server.h
+IGNORE_HFILES= \
+ app-indicator-enum-types.h \
+ application-service-appstore.h \
+ application-service-client.h \
+ application-service-lru-file.h \
+ application-service-marshal.h \
+ application-service-server.h \
+ application-service-watcher.h \
+ dbus-properties-client.h \
+ dbus-properties-server.h \
+ dbus-shared.h \
+ notification-item-client.h \
+ notification-item-server.h \
+ notification-watcher-client.h \
+ notification-watcher-server.h
# Images to copy into HTML directory.
# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png