aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 31 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 599c41b..63f0c64 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1 +1,31 @@
-# Data
+
+libexec_PROGRAMS = indicator-custom-service
+
+##################################
+# Indicator
+##################################
+
+customlibdir = $(INDICATORDIR)
+customlib_LTLIBRARIES = libcustom.la
+libcustom_la_SOURCES = \
+ indicator-custom.c
+libcustom_la_CFLAGS = $(INDICATOR_CFLAGS) \
+ -Wall \
+ -Wl,-Bsymbolic-functions \
+ -Wl,-z,defs \
+ -Wl,--as-needed \
+ -Werror
+libcustom_la_LIBADD = $(INDICATOR_LIBS)
+libcustom_la_LDFLAGS = -module -avoid-version
+
+##################################
+# Service
+##################################
+
+indicator_custom_service_SOURCES = \
+ custom-service.c
+indicator_custom_service_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror
+indicator_custom_service_LDADD = \
+ $(INDICATOR_LIBS)