aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 19ce66d..787ba2f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -49,13 +49,15 @@ indicator_application_service_SOURCES = \
application-service-marshal.c \
application-service-watcher.h \
application-service-watcher.c \
+ app-indicator-enum-types.c \
dbus-shared.h
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
indicator_application_service_LDADD = \
- $(INDICATOR_LIBS)
+ $(INDICATOR_LIBS) \
+ libappindicator.la
glib_marshal_list = application-service-marshal.list
glib_marshal_prefix = _application_service_marshal
@@ -68,19 +70,9 @@ pkgconfig_DATA = appindicator-0.1.pc
pkgconfigdir = $(libdir)/pkgconfig
glib_enum_h = app-indicator-enum-types.h
-glib_enum_c = app-indicator-enum-types.gen.c
+glib_enum_c = app-indicator-enum-types.c
glib_enum_headers = $(addprefix $(srcdir)/, $(libappindicator_headers))
-app-indicator-enum-types.c: app-indicator-enum-types.gen.c
- sed -e "s|\"passive\"|\"Passive\"|" \
- -e "s|\"active\"|\"Active\"|" \
- -e "s|\"attention\"|\"NeedsAttention\"|" \
- -e "s|\"application-status\"|\"ApplicationStatus\"|" \
- -e "s|\"communications\"|\"Communications\"|" \
- -e "s|\"system-services\"|\"SystemServices\"|" \
- -e "s|\"hardware\"|\"Hardware\"|" \
- -e "s|\"other\"|\"Other\"|" \
- $< > $@
DISTCLEANFILES += app-indicator-enum-types.c
lib_LTLIBRARIES = \