aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c94ebdd..327c8cc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,8 @@ check_PROGRAMS = \
TESTS =
DISTCLEANFILES = $(TESTS)
+EXTRA_DIST = run-xvfb.sh
+
#########################################
## test-libappindicator
#########################################
@@ -89,7 +91,8 @@ test_libappindicator_fallback_item_LDADD = \
$(top_builddir)/src/libappindicator.la
test-libappindicator-fallback: test-libappindicator-fallback-watcher test-libappindicator-fallback-item Makefile.am
- @echo "#!/bin/sh" > $@
+ @echo "#!/bin/bash" > $@
+ @echo . $(srcdir)/run-xvfb.sh >> $@
@echo $(DBUS_RUNNER) --task ./test-libappindicator-fallback-watcher --task-name Watcher --ignore-return --task ./test-libappindicator-fallback-item --task-name Item >> $@
@chmod +x $@