aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f6a0525..33fe0ba 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -64,12 +64,17 @@ test_libcustomindicator_dbus_server_LDADD = \
XML_REPORT = libcustomindicator-check-results.xml
HTML_REPORT = libcustomindicator-check-results.html
-libcustomindicator-tests: test-libcustomindicator
- @echo "#!/bin/sh" > libcustomindicator-tests
- @echo gtester -k --verbose -o=$(XML_REPORT) ./test-libcustomindicator >> libcustomindicator-tests
- @chmod +x libcustomindicator-tests
+libcustomindicator-tests: libcustomindicator-tests-gtester Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo $(DBUS_RUNNER) --task ./libcustomindicator-tests-gtester >> $@
+ @chmod +x $@
-TESTS += libcustomindicator-tests
+libcustomindicator-tests-gtester: test-libcustomindicator Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-libcustomindicator >> $@
+ @chmod +x $@
+
+TESTS += libcustomindicator-tests libcustomindicator-tests-gtester
DISTCLEANFILES += $(XML_REPORT) $(HTML_REPORT)