aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6ee3a02..35d557e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -115,6 +115,15 @@ test_approver_LDADD = \
$(INDICATOR_LIBS) \
$(top_builddir)/src/libappindicator.la
+test-approver-tester: test-approver Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo . $(srcdir)/run-xvfb.sh >> $@
+ @echo $(DBUS_RUNNER) --task $(builddir)/test-approver --task-name Approver --task $(top_builddir)/src/indicator-application-service --task-name Service --ignore-return >> $@
+ @chmod +x $@
+
+TESTS += test-approver-tester
+
+
#########################################
## test-libappindicator-fallback
#########################################