aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 82ec364..4044617 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,26 @@
-# Something here
+check_PROGRAMS = \
+ test-libcustomindicator
+
+test_libcustomindicator_SOURCES = \
+ test-libcustomindicator.c
+
+test_libcustomindicator_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -I$(top_srcdir)/src
+
+test_libcustomindicator_LDADD = \
+ $(INDICATOR_LIBS) \
+ $(top_builddir)/src/libcustomindicator.la
+
+XML_REPORT = libcustomindicator-check-results.xml
+HTML_REPORT = libcustomindicator-check-results.html
+
+libcustomindicator-tester: test-libcustomindicator
+ gtester -o=$(XML_REPORT) ./test-libcustomindicator
+
+check-local: libcustomindicator-tester
+
+DISTCLEANFILES = $(XML_REPORT) $(HTML_REPORT)