aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-08-10 04:26:27 +0000
committerTarmac <>2013-08-10 04:26:27 +0000
commitf28653eb1a4a310987fffc44334b93da3f547d41 (patch)
tree82a72bfbb7eeca76766d73ae20f1152c5b8392c3 /configure.ac
parent0391025f72e9e5fed972b40e63087635d50c9234 (diff)
parenta0616908a817d6fad47c29ae703fc8a2ea379af6 (diff)
downloadayatana-indicator-bluetooth-f28653eb1a4a310987fffc44334b93da3f547d41.tar.gz
ayatana-indicator-bluetooth-f28653eb1a4a310987fffc44334b93da3f547d41.tar.bz2
ayatana-indicator-bluetooth-f28653eb1a4a310987fffc44334b93da3f547d41.zip
Add phone profile. Export menus & actions using gio. Drops the gtk, dbusmenu, and libindicator build dependencies. Drops runtime dependency on gnome-blueooth in the phone profile.
Approved by Ted Gould, PS Jenkins bot, Mathieu Trudel-Lapierre.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac71
1 files changed, 29 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index b411913..6eba857 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
-AC_INIT(indicator-bluetooth, 0.0.6)
+AC_INIT([indicator-bluetooth],[13.10.0])
AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz foreign])
+AC_CONFIG_HEADERS([config.h])
AM_SILENT_RULES([yes])
AM_MAINTAINER_MODE
@@ -13,54 +14,40 @@ dnl ###########################################################################
dnl Dependencies
dnl ###########################################################################
-PKG_CHECK_MODULES(INDICATOR_BLUETOOTH_SERVICE, [
- glib-2.0
- gnome-bluetooth-1.0
- indicator3-0.4
- dbusmenu-gtk3-0.4
-])
-
-PKG_CHECK_MODULES(INDICATOR_BLUETOOTH, [
- glib-2.0
- gtk+-3.0
- indicator3-0.4
- dbusmenu-gtk3-0.4
- libido3-0.1
-])
+GLIB_REQUIRED_VERSION=2.36
+GIO_REQUIRED_VERSION=2.36
-dnl ###########################################################################
-dnl Internationalization
-dnl ###########################################################################
+PKG_CHECK_MODULES(SERVICE_DEPS, [glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gio-unix-2.0 >= $GIO_REQUIRED_VERSION])
-IT_PROG_INTLTOOL([0.35.0])
-AC_SUBST(GETTEXT_PACKAGE, indicator-bluetooth)
+dnl ##############################
+dnl # Custom Junk
+dnl ##############################
-with_localinstall="no"
-AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
+AC_DEFUN([AC_DEFINE_PATH], [
+ test "x$prefix" = xNONE && prefix="$ac_default_prefix"
+ test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
+ ac_define_path=`eval echo [$]$2`
+ ac_define_path=`eval echo [$]ac_define_path`
+ $1="$ac_define_path"
+ AC_SUBST($1)
+ ifelse($3, ,
+ AC_DEFINE_UNQUOTED($1, "$ac_define_path"),
+ AC_DEFINE_UNQUOTED($1, "$ac_define_path", $3))
+])
-dnl ###########################################################################
-dnl Indicator Info
-dnl ###########################################################################
+dnl ###########################
+dnl # Internationalization
+dnl ###########################
-AS_IF([test "x$with_localinstall" = "xyes"],
- [
- INDICATORDIR="${libdir}/indicators3/7/"
- ],
- [
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
- ])
-AC_SUBST(INDICATORDIR)
+IT_PROG_INTLTOOL([0.41.0])
-dnl ###########################################################################
-dnl DBus Service Info
-dnl ###########################################################################
+GETTEXT_PACKAGE=indicator-bluetooth
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of the default get text domain])
+AC_DEFINE_PATH(GNOMELOCALEDIR, "${datadir}/locale", [locale directory])
-if test "x$with_localinstall" = "xyes"; then
- DBUSSERVICEDIR="${datadir}/dbus-1/services/"
-else
- DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
-fi
-AC_SUBST(DBUSSERVICEDIR)
+AM_GLIB_GNU_GETTEXT
dnl ###########################################################################
dnl Files to generate