aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-10-26 00:00:22 +0100
committerRobert Tari <robert@tari.in>2020-10-26 00:00:22 +0100
commit73163e638c78e07db623c9e698d00871a9602b3a (patch)
tree4b4b6bd106f6e5315971bf8d150c1cae8756e7e5 /debian/rules
parent5024aafdba098a7c4f481357c206c4cd1437ccf2 (diff)
parent6a5ff48144130ac7384c306458ac227e21aec637 (diff)
downloadayatana-indicator-bluetooth-73163e638c78e07db623c9e698d00871a9602b3a.tar.gz
ayatana-indicator-bluetooth-73163e638c78e07db623c9e698d00871a9602b3a.tar.bz2
ayatana-indicator-bluetooth-73163e638c78e07db623c9e698d00871a9602b3a.zip
Attributes GH PR #2: https://github.com/AyatanaIndicators/ayatana-indicator-bluetooth/pull/2
Merge branch 'sunweaver-pr/ayatana-indicators-port' into master
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 13 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index ca87700..542fd05 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,23 @@
#!/usr/bin/make -f
+NULL =
+
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
- dh $@ --with translations,autoreconf
+ dh $@ --parallel --with systemd --with autoreconf
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
override_dh_install:
- find debian/indicator-bluetooth/usr/lib -name *.la -delete
- find debian/indicator-bluetooth/usr/lib -name *.a -delete
- dh_install --fail-missing
+ dh_install
+ find debian/ayatana-indicator-bluetooth/usr/lib -name *.la -delete
+ find debian/ayatana-indicator-bluetooth/usr/lib -name *.a -delete
+
+override_dh_missing:
+ dh_missing --fail-missing
+
+# For live test logs:
+#override_dh_auto_test:
+# ARGS=-V dh_auto_test