aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-02-05 10:39:34 -0500
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-02-05 10:39:34 -0500
commitca53a577e9708718ffb69ddb96a59acd111e5c1b (patch)
treea987f4a629229babd328bd41da60554d979dd906 /debian/rules
parentf338093bad222b210f00c3843b47afdfece7d8de (diff)
parent7112b9e2f6903dc368e3760da35fea5995c5c499 (diff)
downloadayatana-indicator-bluetooth-ca53a577e9708718ffb69ddb96a59acd111e5c1b.tar.gz
ayatana-indicator-bluetooth-ca53a577e9708718ffb69ddb96a59acd111e5c1b.tar.bz2
ayatana-indicator-bluetooth-ca53a577e9708718ffb69ddb96a59acd111e5c1b.zip
Inline packaging, for autolanding.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ca87700
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
+%:
+ dh $@ --with translations,autoreconf
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
+ find debian/indicator-bluetooth/usr/lib -name *.la -delete
+ find debian/indicator-bluetooth/usr/lib -name *.a -delete
+ dh_install --fail-missing