aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-07-31 23:04:40 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-07-31 23:04:40 -0500
commit761a9fff03812af3c0beb26da1094c69fc3a0a72 (patch)
tree1ef4a2ed2927e62d8449aff72f87942dd4b9320f /src/Makefile.am
parent143845e62636b2bbc1316e794be40c37e3505c71 (diff)
downloadayatana-indicator-bluetooth-761a9fff03812af3c0beb26da1094c69fc3a0a72.tar.gz
ayatana-indicator-bluetooth-761a9fff03812af3c0beb26da1094c69fc3a0a72.tar.bz2
ayatana-indicator-bluetooth-761a9fff03812af3c0beb26da1094c69fc3a0a72.zip
add a vapi/ directory off the top package directory
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8f8d7eb..5fcfc5c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,12 +3,15 @@ indicatordir = ${libdir}/indicators3/7
indicator_LTLIBRARIES = libbluetooth.la
indicator_bluetooth_service_SOURCES = \
- config.vapi \
indicator3-0.4.vapi \
gnome-bluetooth-1.0.vapi \
indicator-bluetooth-service.vala
indicator_bluetooth_service_VALAFLAGS = \
+ --ccode \
+ --vapidir=$(top_srcdir)/vapi/ \
+ --vapidir=./ \
+ --pkg config \
--pkg posix \
--pkg glib-2.0 \
--pkg gtk+-3.0 \
@@ -23,12 +26,14 @@ indicator_bluetooth_service_LDADD = \
$(INDICATOR_BLUETOOTH_SERVICE_LIBS)
libbluetooth_la_SOURCES = \
- config.vapi \
indicator3-0.4.vapi \
indicator-bluetooth.vala \
libido3-0.1.vapi
libbluetooth_la_VALAFLAGS = \
+ --ccode \
+ --vapidir=$(top_srcdir)/vapi/ \
+ --vapidir=./ \
--pkg posix \
--pkg glib-2.0 \
--pkg gtk+-3.0 \