aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-08-05 16:48:17 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-08-05 16:48:17 -0500
commitc1ce02f2b8cd198712606888d08b36f1e7aefe39 (patch)
tree070c84ca09c0041eea98cd4be6be6cc97008470d /src/Makefile.am
parent9837ce82575d089b52269ff600820d565be3fd22 (diff)
downloadayatana-indicator-bluetooth-c1ce02f2b8cd198712606888d08b36f1e7aefe39.tar.gz
ayatana-indicator-bluetooth-c1ce02f2b8cd198712606888d08b36f1e7aefe39.tar.bz2
ayatana-indicator-bluetooth-c1ce02f2b8cd198712606888d08b36f1e7aefe39.zip
fully implement the bluez/device backend. in the desktop profile, add menuitems for the devices.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b5aa8f1..87f4231 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,6 +5,7 @@ indicator_bluetooth_service_SOURCES = \
bluetooth.vala \
bluez.vala \
desktop.vala \
+ device.vala \
main.vala \
phone.vala \
profile.vala \
@@ -15,18 +16,17 @@ indicator_bluetooth_service_VALAFLAGS = \
--ccode \
--vapidir=$(top_srcdir)/vapi/ \
--vapidir=./ \
- --pkg indicator3-0.4 \
- --pkg gnome-bluetooth-1.0 \
--pkg config \
--pkg rfkill \
--pkg posix \
--pkg glib-2.0 \
- --pkg gtk+-3.0 \
- --pkg Dbusmenu-0.4
+ --pkg gtk+-3.0
+# -w to disable warnings for vala-generated code
indicator_bluetooth_service_CFLAGS = \
-DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
-DLOCALE_DIR=\"$(datadir)/locale\" \
+ -w \
$(INDICATOR_BLUETOOTH_SERVICE_CFLAGS)
indicator_bluetooth_service_LDADD = \