aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-08-01 18:21:05 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-08-01 18:21:05 -0500
commitcf894302767d5ec483b5f8002bb796a284895bbf (patch)
treedb2db117dd355db27e72efa9087b8e18a43d38ae /src/Makefile.am
parent3cc732f558737acd0004efb013993515845e67d7 (diff)
downloadayatana-indicator-bluetooth-cf894302767d5ec483b5f8002bb796a284895bbf.tar.gz
ayatana-indicator-bluetooth-cf894302767d5ec483b5f8002bb796a284895bbf.tar.bz2
ayatana-indicator-bluetooth-cf894302767d5ec483b5f8002bb796a284895bbf.zip
add a bluetooth backend to track bluetooth being enabled, being hard/soft blocked, and its devices.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ed2c976..720c981 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,10 +2,14 @@ pkglibexec_PROGRAMS = indicator-bluetooth-service
indicator_bluetooth_service_SOURCES = \
indicator3-0.4.vapi \
+ org-bluez.vala \
+ bluetooth.vala \
+ bluez.vala \
desktop.vala \
main.vala \
menu.vala \
phone.vala \
+ killswitch.vala \
service.vala
indicator_bluetooth_service_VALAFLAGS = \
@@ -14,6 +18,7 @@ indicator_bluetooth_service_VALAFLAGS = \
--vapidir=./ \
--pkg gnome-bluetooth-1.0 \
--pkg config \
+ --pkg rfkill \
--pkg posix \
--pkg glib-2.0 \
--pkg gtk+-3.0 \