aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2012-10-11 08:42:59 +1300
committerRobert Ancell <robert.ancell@canonical.com>2012-10-11 08:42:59 +1300
commitf14da3cc27e2ec514d2e829fd7281f8c5dc9b252 (patch)
tree4efc31d56123a9059d309b41fd3192710409a2bf /src/Makefile.am
downloadayatana-indicator-bluetooth-f14da3cc27e2ec514d2e829fd7281f8c5dc9b252.tar.gz
ayatana-indicator-bluetooth-f14da3cc27e2ec514d2e829fd7281f8c5dc9b252.tar.bz2
ayatana-indicator-bluetooth-f14da3cc27e2ec514d2e829fd7281f8c5dc9b252.zip
First start on bluetooth-indicator
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..101f8f1
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,24 @@
+bin_PROGRAMS = indicator-bluetooth
+
+indicator_bluetooth_SOURCES = \
+ config.vapi \
+ indicator-bluetooth.vala
+
+indicator_bluetooth_VALAFLAGS = \
+ --pkg posix \
+ --pkg glib-2.0 \
+ --pkg gtk+-3.0 \
+ --pkg appindicator3-0.1
+
+indicator_bluetooth_CFLAGS = \
+ -DVERSION=\"$(VERSION)\" \
+ -DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
+ -DLOCALE_DIR=\"$(datadir)/locale\" \
+ $(INDICATOR_BLUETOOTH_CFLAGS)
+
+indicator_bluetooth_LDADD = \
+ $(INDICATOR_BLUETOOTH_LIBS)
+
+CLEANFILES = \
+ $(patsubst %.vala,%.c,$(filter %.vala, $(SOURCES))) \
+ *_vala.stamp