aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 13 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index ca87700..542fd05 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,23 @@
#!/usr/bin/make -f
+NULL =
+
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
- dh $@ --with translations,autoreconf
+ dh $@ --parallel --with systemd --with autoreconf
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
override_dh_install:
- find debian/indicator-bluetooth/usr/lib -name *.la -delete
- find debian/indicator-bluetooth/usr/lib -name *.a -delete
- dh_install --fail-missing
+ dh_install
+ find debian/ayatana-indicator-bluetooth/usr/lib -name *.la -delete
+ find debian/ayatana-indicator-bluetooth/usr/lib -name *.a -delete
+
+override_dh_missing:
+ dh_missing --fail-missing
+
+# For live test logs:
+#override_dh_auto_test:
+# ARGS=-V dh_auto_test