aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2014-01-17 02:06:39 +0000
committerTarmac <Unknown>2014-01-17 02:06:39 +0000
commit4a8f2d77ab357fe62db2a0577db4666e785c06bb (patch)
tree08a752a80cd4dc13629dac8435aadbe48985f8e4 /CMakeLists.txt
parent2c8955bb8c4c2d6914255d914bf2460dfd2723d7 (diff)
parentad76159088202f6e4390843cfed6dd712b8e2544 (diff)
downloadayatana-indicator-datetime-4a8f2d77ab357fe62db2a0577db4666e785c06bb.tar.gz
ayatana-indicator-datetime-4a8f2d77ab357fe62db2a0577db4666e785c06bb.tar.bz2
ayatana-indicator-datetime-4a8f2d77ab357fe62db2a0577db4666e785c06bb.zip
Support both gnome-control-center and unity-control-center. Fixes: https://bugs.launchpad.net/bugs/1257505.
Approved by Charles Kerr, PS Jenkins bot.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ee5cf9..fc8a639 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,6 +54,17 @@ if (PANEL_DEPS_FOUND)
set (BUILD_PANEL 1)
endif ()
+pkg_check_modules (UNITY_PANEL_DEPS
+ glib-2.0>=2.36
+ gio-unix-2.0>=2.36
+ gtk+-3.0>=3.1.4
+ timezonemap
+ libunity-control-center
+ polkit-gobject-1)
+if (UNITY_PANEL_DEPS_FOUND)
+ set (BUILD_UNITY_PANEL 1)
+endif ()
+
##
## custom targets
##
@@ -93,7 +104,10 @@ endif ()
# actually build things
add_subdirectory (src)
if (BUILD_PANEL)
- add_subdirectory (panel)
+ add_subdirectory (panel-gnome)
+endif ()
+if (BUILD_UNITY_PANEL)
+ add_subdirectory (panel-unity)
endif ()
add_subdirectory (data)
add_subdirectory (po)