aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-06 16:03:53 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-06 16:04:05 +0200
commit1843b635ee6388dfa4904f53c7eb8d3ae927ef3d (patch)
tree6d8732c01afdb7a6fee149f9ba93ae472006598f /CMakeLists.txt
parente74f8adce9e648e2b8cd90eb6f52ddecfe3caa00 (diff)
downloadayatana-indicator-datetime-1843b635ee6388dfa4904f53c7eb8d3ae927ef3d.tar.gz
ayatana-indicator-datetime-1843b635ee6388dfa4904f53c7eb8d3ae927ef3d.tar.bz2
ayatana-indicator-datetime-1843b635ee6388dfa4904f53c7eb8d3ae927ef3d.zip
CMakeLists.txt: Move GNUInstallDirs inclusion further up. Inspired by https://github.com/ubports/indicator-datetime/commit/c52883d7bbcece0d532a54cbe179e508586715ed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99dac2a..94d5894 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,8 @@ cmake_minimum_required (VERSION 2.8.9)
list (APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+include (GNUInstallDirs)
+
set (PROJECT_VERSION "0.4.1")
set (PACKAGE ${CMAKE_PROJECT_NAME})
option (enable_tests "Build the package's automatic tests." ON)
@@ -12,7 +14,6 @@ option (enable_lcov "Generate lcov code coverage reports." ON)
## GNU standard installation directories
##
-include (GNUInstallDirs)
set (CMAKE_INSTALL_PKGLIBEXECDIR "${CMAKE_INSTALL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
set (CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")