aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-02 17:13:07 -0500
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-29 14:38:27 +0200
commit6122733b1584e2e80a64ffb04e35c796fe588f6f (patch)
tree2f52ee26d019bd96ed0945dc03ecaac6f07521ad /CMakeLists.txt
parente4fe97eba0160a4d9b1282732cbaea7f8dfb4c7d (diff)
downloadayatana-indicator-datetime-6122733b1584e2e80a64ffb04e35c796fe588f6f.tar.gz
ayatana-indicator-datetime-6122733b1584e2e80a64ffb04e35c796fe588f6f.tar.bz2
ayatana-indicator-datetime-6122733b1584e2e80a64ffb04e35c796fe588f6f.zip
Set the coverage test targeets from where the tests are added.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1378fe4..bb98d9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,8 +125,8 @@ if (${ENABLE_TESTS})
if (${ENABLE_COVERAGE})
find_package(CoverageReport)
ENABLE_COVERAGE_REPORT(
- TARGETS indicatordatetimeservice indicator-datetime-service
- TESTS test-actions test-alarm-queue test-clock test-datetime test-exporter test-formatter test-live-actions test-locations test-menu-appointments test-menus test-notification test-notification-response test-planner test-settings test-sound test-timezone-timedated test-utils test-eds-ics-all-day-events test-eds-ics-repeating-events test-eds-ics-nonrepeating-events test-eds-ics-repeating-valarms test-eds-ics-missing-trigger test-eds-ics-tzids test-eds-ics-tzids-2 test-eds-ics-tzids-utc test-eds-ics-non-attending-alarms test-eds-ics-repeating-events-with-individual-change manual-test-snap
+ TARGETS indicatordatetimeservice ayatana-indicator-datetime-service
+ TESTS ${COVERAGE_TEST_TARGETS}
FILTER /usr/include ${CMAKE_BINARY_DIR}/*
)
endif ()