aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-08-09 21:42:06 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-10 22:07:00 +0200
commit9cea5495892636c808675a189cda190b3c03afbc (patch)
tree6d8efad5ce825bba11e84235e2f9784505e49b25 /CMakeLists.txt
parentbec38167977335d8c33cdc9921c7b483ccd6439b (diff)
downloadayatana-indicator-datetime-9cea5495892636c808675a189cda190b3c03afbc.tar.gz
ayatana-indicator-datetime-9cea5495892636c808675a189cda190b3c03afbc.tar.bz2
ayatana-indicator-datetime-9cea5495892636c808675a189cda190b3c03afbc.zip
Add ENABLE_WERROR option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ff9bf7..33781a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,11 @@ endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
set (PROJECT_VERSION "0.8.3")
set (PACKAGE ${CMAKE_PROJECT_NAME})
+
+# Options
option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
+option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -19,6 +22,11 @@ else()
set(CMAKE_BUILD_TYPE "Release")
endif()
+if(ENABLE_WERROR)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+endif()
+
##
## GNU standard installation directories
##
@@ -146,3 +154,4 @@ endif ()
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
+message(STATUS "Build with -Werror: ${ENABLE_WERROR}")