aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-24 22:17:00 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-24 22:17:00 +0200
commita2a36676eb7265593098e4d22860d7fc50768221 (patch)
tree48b499b19a028499aa84703f04421e32e1016e29 /CMakeLists.txt
parente53de57e8d4d81442e3818dc1454fa3f532ac590 (diff)
downloadayatana-indicator-datetime-a2a36676eb7265593098e4d22860d7fc50768221.tar.gz
ayatana-indicator-datetime-a2a36676eb7265593098e4d22860d7fc50768221.tar.bz2
ayatana-indicator-datetime-a2a36676eb7265593098e4d22860d7fc50768221.zip
CMakeLists.txt: Add libayatana-common (>= 0.9.3) dependency.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 003df0b..dce8c96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ option (ENABLE_COVERAGE "Generate lcov code coverage reports." OFF)
## GNU standard installation directories
##
+include (GNUInstallDirs)
set (CMAKE_INSTALL_PKGLIBEXECDIR "${CMAKE_INSTALL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
set (CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
@@ -41,6 +42,7 @@ include (CheckIncludeFile)
include (FindPkgConfig)
pkg_check_modules (SERVICE_DEPS REQUIRED
+ libayatana-common>=0.9.3
glib-2.0>=2.36
gio-unix-2.0>=2.36
libical>=0.48