aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-02 15:52:03 -0500
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-29 14:38:27 +0200
commite4fe97eba0160a4d9b1282732cbaea7f8dfb4c7d (patch)
tree7b9b0784b5a388d2be48920f712c15a0f32dfa00 /CMakeLists.txt
parent5b555e5b0d23aa429d26795183a63653ef440c77 (diff)
downloadayatana-indicator-datetime-e4fe97eba0160a4d9b1282732cbaea7f8dfb4c7d.tar.gz
ayatana-indicator-datetime-e4fe97eba0160a4d9b1282732cbaea7f8dfb4c7d.tar.bz2
ayatana-indicator-datetime-e4fe97eba0160a4d9b1282732cbaea7f8dfb4c7d.zip
Use cmake-extras for coverage support and always enable testing.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1aebdf3..1378fe4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,9 +94,6 @@ add_custom_target (dist
COMMAND bzr export --root=${ARCHIVE_NAME} ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.gz
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
-add_custom_target (clean-coverage
- COMMAND find ${CMAKE_BINARY_DIR} -name '*.gcda' | xargs rm -f)
-
add_custom_target (cppcheck COMMAND cppcheck --enable=all -q --error-exitcode=2 --inline-suppr
${CMAKE_SOURCE_DIR}/src
${CMAKE_SOURCE_DIR}/tests)
@@ -126,7 +123,12 @@ if (${ENABLE_TESTS})
pkg_check_modules (DBUSTEST REQUIRED dbustest-1>=14.04.0)
enable_testing ()
if (${ENABLE_COVERAGE})
- include(GCov)
+ find_package(CoverageReport)
+ ENABLE_COVERAGE_REPORT(
+ TARGETS indicatordatetimeservice indicator-datetime-service
+ TESTS test-actions test-alarm-queue test-clock test-datetime test-exporter test-formatter test-live-actions test-locations test-menu-appointments test-menus test-notification test-notification-response test-planner test-settings test-sound test-timezone-timedated test-utils test-eds-ics-all-day-events test-eds-ics-repeating-events test-eds-ics-nonrepeating-events test-eds-ics-repeating-valarms test-eds-ics-missing-trigger test-eds-ics-tzids test-eds-ics-tzids-2 test-eds-ics-tzids-utc test-eds-ics-non-attending-alarms test-eds-ics-repeating-events-with-individual-change manual-test-snap
+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+ )
endif ()
endif ()