aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-01-27 11:02:40 -0600
committerCharles Kerr <charles.kerr@canonical.com>2014-01-27 11:02:40 -0600
commitef84548e3025184c4f631a23fceefb008dd6968b (patch)
tree84d25ec1d82475d7b10a7ab0fe4531cfdca3709e /CMakeLists.txt
parentf320760f20b282e9b2695477ab602d4041a3ada8 (diff)
parentad76159088202f6e4390843cfed6dd712b8e2544 (diff)
downloadayatana-indicator-datetime-ef84548e3025184c4f631a23fceefb008dd6968b.tar.gz
ayatana-indicator-datetime-ef84548e3025184c4f631a23fceefb008dd6968b.tar.bz2
ayatana-indicator-datetime-ef84548e3025184c4f631a23fceefb008dd6968b.zip
merge lp:~robert-ancell/indicator-datetime/unity-control-center2 into lp:indicator-datetime
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf34ebb..53a3f7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,17 @@ if (PANEL_DEPS_FOUND)
set (BUILD_PANEL 1)
endif ()
+pkg_check_modules (UNITY_PANEL_DEPS
+ glib-2.0>=2.36
+ gio-unix-2.0>=2.36
+ gtk+-3.0>=3.1.4
+ timezonemap
+ libunity-control-center
+ polkit-gobject-1)
+if (UNITY_PANEL_DEPS_FOUND)
+ set (BUILD_UNITY_PANEL 1)
+endif ()
+
##
## custom targets
##
@@ -97,7 +108,10 @@ endif ()
add_subdirectory(include)
add_subdirectory(src)
if (BUILD_PANEL)
- add_subdirectory(panel)
+ add_subdirectory (panel-gnome)
+endif ()
+if (BUILD_UNITY_PANEL)
+ add_subdirectory (panel-unity)
endif ()
add_subdirectory(data)
add_subdirectory(po)