aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-27 22:21:09 +0200
committerRobert Tari <robert@tari.in>2021-05-11 13:33:48 +0200
commitfc83ab818ab55ecf346e5eec7c9d806107893219 (patch)
tree60a8a695a24e669b00d073420d697e66cec6f624 /CMakeLists.txt
parent6bfcd372e85150aed1a55cb6bb2252c6fe115384 (diff)
downloadayatana-indicator-datetime-fc83ab818ab55ecf346e5eec7c9d806107893219.tar.gz
ayatana-indicator-datetime-fc83ab818ab55ecf346e5eec7c9d806107893219.tar.bz2
ayatana-indicator-datetime-fc83ab818ab55ecf346e5eec7c9d806107893219.zip
CMakeLists.txt: Rename CMake options 'enable_tests' to 'ENABLE_TESTS' and 'enable_lcov' to 'ENABLE_COVERAGE' (both defaulting to 'OFF').
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf3b2fb..32a3877 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,8 @@ include (GNUInstallDirs)
set (PROJECT_VERSION "0.8.3")
set (PACKAGE ${CMAKE_PROJECT_NAME})
-option (enable_tests "Build the package's automatic tests." ON)
-option (enable_lcov "Generate lcov code coverage reports." ON)
+option (ENABLE_TESTS "Build the package's automatic tests." OFF)
+option (ENABLE_COVERAGE "Generate lcov code coverage reports." OFF)
##
## GNU standard installation directories
@@ -105,7 +105,7 @@ include_directories (${CMAKE_CURRENT_SOURCE_DIR}/include)
include_directories (${CMAKE_CURRENT_BINARY_DIR}/include)
# testing & coverage
-if (${enable_tests})
+if (${ENABLE_TESTS})
pkg_check_modules (DBUSTEST REQUIRED dbustest-1>=14.04.0)
if (EXISTS /usr/src/googletest/src)
@@ -117,7 +117,7 @@ if (${enable_tests})
set (GTEST_INCLUDE_DIR ${GTEST_SOURCE_DIR}/..)
set (GTEST_LIBS -lpthread)
enable_testing ()
- if (${enable_lcov})
+ if (${ENABLE_COVERAGE})
include(GCov)
endif ()
endif ()
@@ -127,6 +127,6 @@ add_subdirectory(include)
add_subdirectory(src)
add_subdirectory(data)
add_subdirectory(po)
-if (${enable_tests})
+if (${ENABLE_TESTS})
add_subdirectory(tests)
endif ()