aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-10-24 13:33:32 -0400
committerTed Gould <ted@gould.cx>2010-10-24 13:33:32 -0400
commit8c7b43feb747bd6bfb3b5f326f2f4451ffc248d9 (patch)
tree86eec530fcef7669d0e00ef135b871d1d8e46639 /Makefile.am
parentc10092cc091880a55138bbd23597ef0043115ce7 (diff)
parentb177ae16875ce554aeb00186996e6fbe01ed109d (diff)
downloadayatana-indicator-datetime-8c7b43feb747bd6bfb3b5f326f2f4451ffc248d9.tar.gz
ayatana-indicator-datetime-8c7b43feb747bd6bfb3b5f326f2f4451ffc248d9.tar.bz2
ayatana-indicator-datetime-8c7b43feb747bd6bfb3b5f326f2f4451ffc248d9.zip
* Upstream Merge
* Add in Geoclue support for setting proper timezone * debian/control: Add recommends for ubuntu-geoip * debian/control: Adding dependencies on Geoclue and OOBS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b2bca4..a692889 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,3 +22,15 @@ dist-hook:
else \
echo Failed to generate ChangeLog: not a branch >&2; \
fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi