aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-07 12:34:12 -0500
committerTed Gould <ted@gould.cx>2010-09-07 12:34:12 -0500
commit029d2cfd3c57be5c9c0c98ccafda09e92e92afe7 (patch)
tree385fcd26c79fe4737bbbdd2fb862cf1637105ce7 /configure.ac
parentcc5ecca1e9d029b3ab2853daf4328112a5c32f03 (diff)
parentd0f7670cc5c25a89c734ace8a442278b982c3caa (diff)
downloadayatana-indicator-datetime-029d2cfd3c57be5c9c0c98ccafda09e92e92afe7.tar.gz
ayatana-indicator-datetime-029d2cfd3c57be5c9c0c98ccafda09e92e92afe7.tar.bz2
ayatana-indicator-datetime-029d2cfd3c57be5c9c0c98ccafda09e92e92afe7.zip
Import upstream version 0.0.5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fdc85c2..726fe16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-AC_INIT(indicator-datetime, 0.0.4, ted@canonical.com)
+AC_INIT(indicator-datetime, 0.0.5, ted@canonical.com)
AC_COPYRIGHT([Copyright 2009,2010 Canonical])
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-datetime, 0.0.4)
+AM_INIT_AUTOMAKE(indicator-datetime, 0.0.5)
AM_MAINTAINER_MODE
@@ -35,15 +35,26 @@ PKG_PROG_PKG_CONFIG
INDICATOR_REQUIRED_VERSION=0.3.0
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+GIO_REQUIRED_VERSION=2.25.11
+# Note: the GIO check below also ensures the proper glib with gsettings support is present
+INDICATOR_DISPLAY_OBJECTS=0.1.10
PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
###########################
+# Grab the GSettings Macros
+###########################
+
+GLIB_GSETTINGS
+
+###########################
# Check to see if we're local
###########################