aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Terry <mike@mterry.name>2011-02-28 08:28:17 -0500
committerMichael Terry <mike@mterry.name>2011-02-28 08:28:17 -0500
commite7442e09fecff816aa195e8aaff27192d3c64b6b (patch)
treeb53540826e884fec0e4cf97ddb5e086e0a5a634f /configure.ac
parent6b80729a4f344068c520b262ae82b3c5d903c698 (diff)
parentbb010c63b54c58a6dc63f86d6c0338d9502328bc (diff)
downloadayatana-indicator-datetime-e7442e09fecff816aa195e8aaff27192d3c64b6b.tar.gz
ayatana-indicator-datetime-e7442e09fecff816aa195e8aaff27192d3c64b6b.tar.bz2
ayatana-indicator-datetime-e7442e09fecff816aa195e8aaff27192d3c64b6b.zip
* New upstream release.0.1.95-0ubuntu1
- New preference dialog - Improved EDS support - Improved timezone support * debian/control: - Update Build-Depends
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 41 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d06aa6d..a762ea8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-AC_INIT(indicator-datetime, 0.1.94, ted@canonical.com)
+AC_INIT(indicator-datetime, 0.1.95, ted@canonical.com)
AC_COPYRIGHT([Copyright 2009,2010 Canonical])
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-datetime, 0.1.94)
+AM_INIT_AUTOMAKE(indicator-datetime, 0.1.95)
AM_MAINTAINER_MODE
@@ -65,6 +65,8 @@ ICAL_REQUIRED_VERSION=0.44
CAIRO_REQUIRED_VERSION=1.10
GDK_REQUIRED_VERSION=2.22
GLIB_REQUIRED_VERSION=2.26
+GTK_REQUIRED_VERSION=2.12
+GTK3_REQUIRED_VERSION=3.0
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(INDICATOR, indicator3 >= $INDICATOR_REQUIRED_VERSION
@@ -117,12 +119,48 @@ AS_IF([test "x$with_gtk" = x3],
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
+
+# FIXME: polkit-gtk-1 isn't gtk3-compatible
+AS_IF([test "x$with_gtk" = x3],
+ [PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ unique-3.0
+ json-glib-1.0
+ polkit-gtk-1)
+ ],
+ [test "x$with_gtk" = x2],
+ [PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ unique-1.0
+ json-glib-1.0
+ polkit-gtk-1)
+ ],
+ [AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
+)
+
+AS_IF([test "x$with_gtk" = x3],
+ [PKG_CHECK_MODULES(LIBMAP, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION)
+ ],
+ [test "x$with_gtk" = x2],
+ [PKG_CHECK_MODULES(LIBMAP, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION)
+ ],
+ [AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
+)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
AC_SUBST(SERVICE_CFLAGS)
AC_SUBST(SERVICE_LIBS)
+AC_SUBST(PREF_CFLAGS)
+AC_SUBST(PREF_LIBS)
+
+AC_SUBST(LIBMAP_CFLAGS)
+AC_SUBST(LIBMAP_LIBS)
+AC_SUBST(LIBMAP_LDFLAGS)
+
###########################
# Grab the GSettings Macros
###########################
@@ -202,6 +240,7 @@ AM_GLIB_GNU_GETTEXT
AC_OUTPUT([
Makefile
+libmap/Makefile
src/Makefile
data/Makefile
tests/Makefile