aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-12 16:55:18 -0500
committerTed Gould <ted@gould.cx>2010-07-12 16:55:18 -0500
commit89692e244aab0cf3f3dba3bb489c026be8b386e1 (patch)
treef65e401c5c0221a3622f43017ab2522224360bb1 /configure.ac
parent667f56dcaffbbdf9c29b5f0d17fa1293d9d464bc (diff)
downloadayatana-indicator-datetime-89692e244aab0cf3f3dba3bb489c026be8b386e1.tar.gz
ayatana-indicator-datetime-89692e244aab0cf3f3dba3bb489c026be8b386e1.tar.bz2
ayatana-indicator-datetime-89692e244aab0cf3f3dba3bb489c026be8b386e1.zip
Bringing in the gesttings love.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9bf0a3c..460aadc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,15 +35,23 @@ PKG_PROG_PKG_CONFIG
INDICATOR_REQUIRED_VERSION=0.3.0
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+GIO_REQUIRED_VERSION=2.25.0
PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
###########################
+# Grab the GSettings Macros
+###########################
+
+GLIB_GSETTINGS
+
+###########################
# Check to see if we're local
###########################