aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Terry <mike@mterry.name>2011-02-17 14:30:43 -0500
committerMichael Terry <mike@mterry.name>2011-02-17 14:30:43 -0500
commita10f207618976b59a0cc43c01befbf67128c92a5 (patch)
treede34a6202fd5bb2a42e7871c4c026ec583b6ae98 /configure.ac
parent37fc0a3158e5ff5f8cf9096de49451379c2d11f1 (diff)
downloadayatana-indicator-datetime-a10f207618976b59a0cc43c01befbf67128c92a5.tar.gz
ayatana-indicator-datetime-a10f207618976b59a0cc43c01befbf67128c92a5.tar.bz2
ayatana-indicator-datetime-a10f207618976b59a0cc43c01befbf67128c92a5.zip
first pass at preferences dialog
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f35d38..3cf45ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,8 @@ EDS_REQUIRED_VERSION=2.30
ICAL_REQUIRED_VERSION=0.44
CAIRO_REQUIRED_VERSION=1.10
GDK_REQUIRED_VERSION=2.22
+GTK_REQUIRED_VERSION=2.12
+GTK3_REQUIRED_VERSION=3.0
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(INDICATOR, indicator3 >= $INDICATOR_REQUIRED_VERSION
@@ -110,12 +112,28 @@ AS_IF([test "x$with_gtk" = x3],
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
+
+AS_IF([test "x$with_gtk" = x3],
+ [PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ unique-3.0)
+ ],
+ [test "x$with_gtk" = x2],
+ [PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ unique-1.0)
+ ],
+ [AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
+)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
AC_SUBST(SERVICE_CFLAGS)
AC_SUBST(SERVICE_LIBS)
+AC_SUBST(PREF_CFLAGS)
+AC_SUBST(PREF_LIBS)
+
###########################
# Grab the GSettings Macros
###########################