aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-19 07:51:27 -0500
committerTed Gould <ted@gould.cx>2010-07-19 07:51:27 -0500
commitf345a7803aab7db94a64d5e3ad2ef1b8236a0b0e (patch)
tree7ec242f396c6beddd5e5268a8df61a47cca250fe /configure.ac
parentf315167e590a969bc857695b22feeba4ddd1539d (diff)
parent4f161374f428a9b7182d292b45679120326d1ab8 (diff)
downloadayatana-indicator-datetime-f345a7803aab7db94a64d5e3ad2ef1b8236a0b0e.tar.gz
ayatana-indicator-datetime-f345a7803aab7db94a64d5e3ad2ef1b8236a0b0e.tar.bz2
ayatana-indicator-datetime-f345a7803aab7db94a64d5e3ad2ef1b8236a0b0e.zip
* Upstream Merge
* Making time format configurable via translations and gsettings. * debian/control: Adding in a glib dependency to get gsettings * Autogen update
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fdc85c2..f8997bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,15 +35,23 @@ PKG_PROG_PKG_CONFIG
INDICATOR_REQUIRED_VERSION=0.3.0
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+GIO_REQUIRED_VERSION=2.25.0
PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
###########################
+# Grab the GSettings Macros
+###########################
+
+GLIB_GSETTINGS
+
+###########################
# Check to see if we're local
###########################