aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-09-09 13:28:51 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-09-09 13:28:51 +0200
commit18e9350ddf455cce186eb3d0a428364fc521fd5b (patch)
tree45c2185504ee01a552512ffe72589f038db4560e /data/CMakeLists.txt
parent0d2c8f74be593014099a61c0e3089d80399ef3dd (diff)
parent1536c23e36666f89f9a03e2e8992c8917cced74d (diff)
downloadayatana-indicator-datetime-18e9350ddf455cce186eb3d0a428364fc521fd5b.tar.gz
ayatana-indicator-datetime-18e9350ddf455cce186eb3d0a428364fc521fd5b.tar.bz2
ayatana-indicator-datetime-18e9350ddf455cce186eb3d0a428364fc521fd5b.zip
Merge branch 'tari01-pr/fix-schema-translation'
Attributes GH PR #113: https://github.com/AyatanaIndicators/ayatana-indicator-datetime/pull/113
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 2e1cdfa..726bcec 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -3,15 +3,10 @@
##
set (SCHEMA_NAME "org.ayatana.indicator.datetime.gschema.xml")
-set (SCHEMA_FILE_IN_IN "${CMAKE_CURRENT_SOURCE_DIR}/${SCHEMA_NAME}.in.in")
-set (SCHEMA_FILE_IN "${CMAKE_CURRENT_BINARY_DIR}/${SCHEMA_NAME}.in")
+set (SCHEMA_FILE_IN "${CMAKE_CURRENT_SOURCE_DIR}/${SCHEMA_NAME}.in")
set (SCHEMA_FILE "${CMAKE_CURRENT_BINARY_DIR}/${SCHEMA_NAME}")
# generate the .xml.in file so cmake constants are included
-configure_file(${SCHEMA_FILE_IN_IN} ${SCHEMA_FILE_IN})
-# generate the .xml file using intltool
-find_package(Intltool REQUIRED)
-set (ENV{LC_ALL} "C")
-intltool_merge_translations("${SCHEMA_FILE_IN}" "${SCHEMA_FILE}" ALL UTF8 STYLE "xml" NO_TRANSLATIONS)
+configure_file(${SCHEMA_FILE_IN} ${SCHEMA_FILE})
# let GSettings do the rest
find_package(GSettings REQUIRED)