aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-08 13:26:52 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-08 13:26:52 +0100
commit3eb2ae42d544490a69c2e0e0d251664f0e9f0a3a (patch)
treed6d0e89121f143ec3eb48293fe70da283c9d87ce /data/CMakeLists.txt
parent438baee6b0114dfd2d6df1e915f29cd7511e9a2b (diff)
downloadayatana-indicator-datetime-3eb2ae42d544490a69c2e0e0d251664f0e9f0a3a.tar.gz
ayatana-indicator-datetime-3eb2ae42d544490a69c2e0e0d251664f0e9f0a3a.tar.bz2
ayatana-indicator-datetime-3eb2ae42d544490a69c2e0e0d251664f0e9f0a3a.zip
Use GSettings cmake module from cmake-extras.
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 28b2e17..ce463a0 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -2,17 +2,9 @@
## GSettings schema
##
-include (UseGSettings)
-set (SCHEMA_NAME "org.ayatana.indicator.datetime.gschema.xml")
-set (SCHEMA_FILE "${CMAKE_CURRENT_BINARY_DIR}/${SCHEMA_NAME}")
-set (SCHEMA_FILE_IN "${CMAKE_CURRENT_SOURCE_DIR}/${SCHEMA_NAME}.in")
+find_package (GSettings)
-# generate the .xml file using intltool
-set (ENV{LC_ALL} "C")
-execute_process (COMMAND intltool-merge -quiet --xml-style --utf8 --no-translations "${SCHEMA_FILE_IN}" "${SCHEMA_FILE}")
-
-# let UseGSettings do the rest
-add_schema (${SCHEMA_FILE})
+add_schema ("org.ayatana.indicator.datetime.gschema.xml")
##
## Upstart Job File