aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-10-30 23:49:58 +0000
committerTarmac <Unknown>2013-10-30 23:49:58 +0000
commitbbc781d9e2afe500d9a5d09335f0954f25269be6 (patch)
tree87ad870ab7d39777686e4f9661bcaa4ba41b5e1d /debian/rules
parent19ba64b479fd14d5192f0ec3dcc37fe33bde238b (diff)
parent13cc891202d3721fc157c827ed1141ee6221ccbd (diff)
downloadayatana-indicator-datetime-bbc781d9e2afe500d9a5d09335f0954f25269be6.tar.gz
ayatana-indicator-datetime-bbc781d9e2afe500d9a5d09335f0954f25269be6.tar.bz2
ayatana-indicator-datetime-bbc781d9e2afe500d9a5d09335f0954f25269be6.zip
Switch the build system to cmake. Fixes: https://bugs.launchpad.net/bugs/1237509.
Approved by Ted Gould, PS Jenkins bot.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 2 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 25854b8..0e7a91f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,17 +3,11 @@
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
%:
- dh $@ --with quilt,autoreconf
-
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
-
-override_dh_auto_configure:
- dh_auto_configure -- --disable-static --disable-silent-rules
+ dh $@ --with translations
override_dh_install:
cd po; intltool-update --pot --verbose
- dh_install -X.la --fail-missing
+ dh_install --fail-missing
# Language packs
for d in $$(find debian/indicator-datetime -type f \( -name "*.desktop" -o -name "*.directory" \) ); do \
sed -ri '/^(Name|GenericName|Comment|X-GNOME-FullName)\[/d' $$d; \