aboutsummaryrefslogtreecommitdiff
path: root/panel-unity/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2014-01-17 02:06:39 +0000
committerTarmac <Unknown>2014-01-17 02:06:39 +0000
commit4a8f2d77ab357fe62db2a0577db4666e785c06bb (patch)
tree08a752a80cd4dc13629dac8435aadbe48985f8e4 /panel-unity/CMakeLists.txt
parent2c8955bb8c4c2d6914255d914bf2460dfd2723d7 (diff)
parentad76159088202f6e4390843cfed6dd712b8e2544 (diff)
downloadayatana-indicator-datetime-4a8f2d77ab357fe62db2a0577db4666e785c06bb.tar.gz
ayatana-indicator-datetime-4a8f2d77ab357fe62db2a0577db4666e785c06bb.tar.bz2
ayatana-indicator-datetime-4a8f2d77ab357fe62db2a0577db4666e785c06bb.zip
Support both gnome-control-center and unity-control-center. Fixes: https://bugs.launchpad.net/bugs/1257505.
Approved by Charles Kerr, PS Jenkins bot.
Diffstat (limited to 'panel-unity/CMakeLists.txt')
-rw-r--r--panel-unity/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/panel-unity/CMakeLists.txt b/panel-unity/CMakeLists.txt
new file mode 100644
index 0000000..f710006
--- /dev/null
+++ b/panel-unity/CMakeLists.txt
@@ -0,0 +1,26 @@
+set (PANEL_LIB "unity-indicator-datetime")
+
+add_definitions (-DPKGDATADIR="${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/${CMAKE_PROJECT_NAME}")
+
+add_library (${PANEL_LIB} SHARED
+ ${CMAKE_SOURCE_DIR}/panel/datetime-prefs.c
+ ${CMAKE_SOURCE_DIR}/panel/datetime-prefs-locations.c
+ ${CMAKE_SOURCE_DIR}/panel/datetime-prefs-locations.h
+ ${CMAKE_SOURCE_DIR}/src/utils.c
+ ${CMAKE_SOURCE_DIR}/src/utils.h
+ ${CMAKE_SOURCE_DIR}/src/settings-shared.h)
+set_property (TARGET ${PANEL_LIB} PROPERTY OUTPUT_NAME indicator-datetime)
+
+include_directories (${UNITY_PANEL_DEPS_INCLUDE_DIRS})
+
+link_directories (${UNITY_PANEL_DEPS_LIBRARY_DIRS})
+
+set_property (TARGET ${PANEL_LIB}
+ APPEND_STRING PROPERTY COMPILE_FLAGS
+ " -g ${CC_WARNING_ARGS} ${GCOV_FLAGS} -DUSE_UNITY")
+
+target_link_libraries (${PANEL_LIB} ${UNITY_PANEL_DEPS_LIBRARIES} ${GCOV_LIBS})
+
+install (TARGETS ${PANEL_LIB}
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/unity-control-center-1/panels)
+