aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2015-01-28 19:15:59 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2015-01-28 19:15:59 +0000
commite1f1be9e181a3d00506b77c6201178e030fc0168 (patch)
tree5a0d7e2b25bc47903452446be831a9b6495f7238 /src/CMakeLists.txt
parentfe5d8d46225d9144e2c756c9d206d2ac73f6ad77 (diff)
parent12c742122d34578b23da54d49d4ae1b9bb6af87e (diff)
downloadayatana-indicator-datetime-e1f1be9e181a3d00506b77c6201178e030fc0168.tar.gz
ayatana-indicator-datetime-e1f1be9e181a3d00506b77c6201178e030fc0168.tar.bz2
ayatana-indicator-datetime-e1f1be9e181a3d00506b77c6201178e030fc0168.zip
Don't play calendar alarm sounds if Silent Mode is enabled. Use the alarm sound role for both clock and calendar alarms. Fixes: #1410874
Approved by: Antti Kaijanmäki, PS Jenkins bot
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 512cc5c..5fc822c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -47,6 +47,9 @@ set(SERVICE_GENERATED_SOURCES)
add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-alarm-properties
com.canonical.indicator
${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.datetime.AlarmProperties.xml)
+add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-accounts-sound
+ com.ubuntu.touch
+ ${CMAKE_SOURCE_DIR}/src/com.ubuntu.touch.AccountsService.Sound.xml)
# add warnings/coverage info on handwritten files
# but not the autogenerated ones...