aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-08-19 20:19:10 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-08-19 20:19:10 +0000
commit341cbc193c007e68f9d6591bad84ba0af70884ec (patch)
tree87031c44d7b8861055cb7c3cdb8df0a9b14aa10a /src/CMakeLists.txt
parent139454ce848864a96db9ff1acf0552060ca2bbd8 (diff)
parenta144696c42e5048083abbe6a08528ed57526fa07 (diff)
downloadayatana-indicator-datetime-341cbc193c007e68f9d6591bad84ba0af70884ec.tar.gz
ayatana-indicator-datetime-341cbc193c007e68f9d6591bad84ba0af70884ec.tar.bz2
ayatana-indicator-datetime-341cbc193c007e68f9d6591bad84ba0af70884ec.zip
Use powerd's hardware wakeup API instead of of using the u_hardware_alarm_*() API directly.
Approved by: Antti Kaijanmäki, PS Jenkins bot
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a466a48..e583334 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -35,10 +35,8 @@ set (SERVICE_CXX_SOURCES
timezone-geoclue.cpp
timezones-live.cpp
utils.c
- wakeup-timer-mainloop.cpp)
-if (HAVE_UBUNTU_HW_ALARM_H)
- set (SERVICE_CXX_SOURCES ${SERVICE_CXX_SOURCES} wakeup-timer-uha.cpp)
-endif ()
+ wakeup-timer-mainloop.cpp
+ wakeup-timer-powerd.cpp)
# generated sources
include (GdbusCodegen)